Переполнение счетчика номера недели GPS (GPS WNRO)

Переполнение счетчика номера недели GPS (GPS WNRO)

06 апреля 2019 г. радионавигационным приемникам, использующим в своей работе сигналы глобальной сетевой спутниковой радионавигационной системы NAVSTAR (GPS),  предстоит функционировать в условиях наступления важного системного события, получившего название GPS WNRO (GPS Week Number Rollover). В начале новых суток по шкале времени GPS произойдет второе по счету переполнение 10-разрядного двоичного счетчика номера недели в навигационном сообщении, отсчитываемого с момента запуска системы в январе 1980 г. , со сбросом его максимального значения 1023 в ноль. Впервые подобное событие имело место 19.7 лет назад, 21 августа 1999 г.

Компания Trimble ответственно относится к проверке своих продуктов и решений в части их готовности к данному событию, а также стремится надлежащим образом информировать об этом своих пользователей и партнеров. Заблаговременно были проведены испытания с использованием имитаторов сигналов GPS с тем, чтобы убедиться, что микропрограммное обеспечение (МПО) приемников ГНСС Trimble штатно отрабатывает событие GPS WNRO в различных режимах работы, включая съемку в реальном масштабе времени и с постобработкой результатов измерений с целым рядом входящих и исходящих сообщений, осуществляя при этом корректное преобразование файлов данных.  Рекомендации по итогам выполненной проверки приведены ниже (материал дополняется).

Рекомендуется обновить МПО геодезических приемников ГНСС Trimble до текущей версии с помощью ПО Trimble Installation Manager или Trimble WinFlash. Все приемники, произведенные после 2000 г. , с версией МПО 2.32 и старше будут штатно функционировать после наступления события GPS WNRO. Далее указаны наименования приемников с минимальной / рекомендованной версиями МПО.

  • Trimble 5700-1: 2.32 / 2.32
  • Trimble 5700-2: любая / 4.90
  • Trimble 5800-1: 2.32 / 2.32
  • Trimble 5800-2: любая / 4.43
  • Trimble R2: любая / 5.40
  • Trimble R4-1: любая / 4.64
  • Trimble R4-2: любая / 5.40
  • Trimble R4-3: любая / 5.40
  • Trimble R5: любая / 5.00
  • Trimble R6-1: любая / 4.64
  • Trimble R6-2: любая / 4.64
  • Trimble R6-3: любая / 5.40
  • Trimble R6-4: любая / 5.40
  • Trimble R7 GNSS: любая / 5.00
  • Trimble R8-1: 2.32 / 2.32
  • Trimble R8-2: любая / 4.64
  • Trimble R8-3: любая / 5.40
  • Trimble R8-4: любая / 5.40
  • Trimble R8s: любая / 5.40
  • Trimble R9s: любая / 5.40
  • Trimble R10: любая / 5.40
  • Trimble R10 LT: любая / 5.40
  • Trimble R10-2: любая / 5.40
  • Trimble NetR9 Geospatial: любая / 5.40

Файлы сырых измерений, записанных приемниками ГНСС Trimble 4700 и 4800 14 февраля 2016 г. и позднее, подлежат корректировке в части номера недели GPS с помощью утилиты FixDATWeek.

Геодезические полевые контроллеры Trimble со встроенным приемником ГНСС будут штатно функционировать после наступления события WNRO. Далее указаны наименования контроллеров с типом встроенного приемника ГНСС и минимальной версией МПО.

  • Trimble TSC7: uBlox M8N, любая
  • Trimble TSC3: SiRFStar III / SiRFStar IV, любая
  • Trimble T10: NEO-M8N / NEO-M8T, любая
  • Trimble Tablet Rugged PC: uBlox Neo-6T, любая
  • Trimble Tablet Rugged PC (Enhanced GPS): uBlox Neo-7P, любая
  • Trimble Slate: uBlox Neo-6T, любая
  • Trimble EM100: Trimble, не требуется

Рекомендуется обновить МПО приемников Trimble для картографии и ГИС до текущей версии. Все приемники, произведенные после 2005 г. , будут штатно функционировать после наступления события GPS WNRO с текущей версией МПО. Далее указаны наименования приемников с минимальной / рекомендованной версиями МПО.

  • Trimble GeoExplorer 2008: 2.11 / 2.11
  • Trimble GeoExplorer 3000: 2.11 / 2.11
  • Trimble GeoExplorer 6000: любая / 3.06.1 и выше
  • Trimble Geo 5T: 1.05.1 / 1.05.1 и выше
  • Trimble Geo 7X: любая / 4.50.3 и выше
  • Trimble GPS Pathfinder Pro 6T/6H: любая / 3.15 (системное МПО 1.03)
  • Trimble GPS Pathfinder ProXT/XH: 2.07 / 2.07 и выше
  • Trimble GPS Pathfinder ProXRT: любая / 4.44 и выше
  • Trimble Juno S: любая / 5.0.2 и выше
  • Trimble Juno 3: любая / 1.03.1 и выше
  • Trimble Juno 5: любая / 1.0.8 и выше
  • Trimble Nomad 900: любая / 1.2.2.0 и выше
  • Trimble Nomad 1050: любая / 2.0 и выше
  • Trimble Nomad 5: любая / 20181005-0209 и выше
  • Trimble Yuma: любая / R0.7 и выше
  • Trimble Yuma 2: любая / 1.0.0.14 и выше
  • Trimble R2: любая / 5.40 и выше
  • Trimble R1: любая / 5.09 и выше
  • Trimble T10: любая
  • Trimble EM100: любая / 5.32 и выше
  • Trimble TDC100: любая
  • Trimble TDC150: 3.67 / 3.67 и выше
  • Trimble Catalyst: Catalyst Service 1.1.2197 / Catalyst Service 1.1.2197 и выше

Геодезическим приемникам ГНСС Spectra Geospatial требуется обновление МПО до версии, не ниже упомянутой далее минимальной, до момента наступления события GPS WNRO. Далее указаны наименования приемников с минимальной / рекомендованной версиями МПО.

  • Spectra Geospatial SP90m: 3.68* / 3.68
  • Spectra Geospatial SP80: 3.38** / 3.38
  • Spectra Geospatial SP60: 3.38** / 3.81
  • Spectra Geospatial SP20: 3.67 / 3.67
  • Spectra Geospatial MobileMapper 50: любая
  • Spectra Geospatial ProMark 800: 1.9.S815Kn27 / 1.9.S815Kn27
  • Spectra Geospatial ProFlex 800: 2.06.S850Kn27 / 2.06.S850Kn27
  • Spectra Geospatial ProMark 700: любая
  • Spectra Geospatial ProMark 100/200: 2.5.aW215Hm27 / 2.5.aW215Hm27
  • Spectra Geospatial ProMark 120/220: 2.5.aW215Hm27 / 2.5.aW215Hm27
  • Spectra Geospatial MobileMapper 100/120: 2.5.aW215Hm27 / 2.5.aW215Hm27
  • Spectra Geospatial MobileMapper 300: любая
  • Spectra Geospatial EPOCH 50: любая
  • Spectra Geospatial EPOCH 35: любая
  • Spectra Geospatial EPOCH 25: 2.32 / 2.32
  • Spectra Geospatial EPOCH 10: любая
  • Spectra Geospatial ProMark 500: 6.8.S814G126 / 6.8.S814G126
  • Spectra Geospatial ProFlex 500: 4.5.S767G224 / 4.5.S767G224
  • Spectra Geospatial ProMark 3: любая
  • Spectra Geospatial MobileMapper 10: любая
  • Spectra Geospatial MobileMapper 6: любая
  • Spectra Geospatial MobileMapper CX: любая
  • Spectra Geospatial MobileMapper CE: любая
  • Spectra Geospatial MobileMapper 20: любая
  • Spectra Geospatial ProMark 2: любая

* требуется SP Loader 7.1.0 или выше

** в случае истекшего срока обновления МПО требуется SP Loader 8.8 или выше

Геодезические полевые контроллеры Spectra Geospatial со встроенным приемником ГНСС будут штатно функционировать после наступления события WNRO. Далее указаны наименования контроллеров с типом встроенного приемника ГНСС и минимальной версией МПО.

  • Spectra Geospatial Ranger 7: SiRFStar IV, любая
  • Spectra Geospatial Ranger 3: SiRFStar III / SiRFStar IV, любая
  • Spectra Geospatial ST10: NEO-M8N / NEO-M8T, любая
  • Spectra Geospatial Nomad 1050: SiRFStar IV, любая
  • Spectra Geospatial T41: uBlox Neo-6T, любая
  • Spectra Geospatial T41 (Enhanced GPS): uBlox Neo-7P, любая

МПО приемников ГНСС Spectra Geospatial указанных выше минимальных версий обратно совместимо с полевым программным обеспечением (ПО) Survey Pro текущей версии 6.4.1. Полевое ПО Survey Pro версии 5.5.2 и ниже не совместимо с МПО приемников ГНСС Spectra Geospatial указанных выше минимальных версий. Пользователям приемников ГНСС Spectra Geospatial  SP60 и SP80 с МПО версии 3.38 и выше следует установить полевое ПО Survey Pro версии 5.6.4; такая установка возможна при наличии лицензии на использование ПО Survey Pro версии 5.4 и выше.

Геодезическим приемникам ГНСС Руснавгеосеть требуется обновление МПО до версии, не ниже упомянутой далее минимальной, до момента наступления события GPS WNRO. Далее указаны наименования приемников с минимальной / рекомендованной версиями МПО.

* в случае истекшего срока обновления МПО требуется SP Loader 8.8

Офисное программное обеспечение Trimble Business Center версий 4.10.3 и 5.00.2 и Spectra Precision Survey Office версии 4.10.3 корректно обрабатывают данные, измеренные геодезическими приемниками ГНСС Trimble и Spectra Geospatial, штатно функционирующими после наступления события GPS WNRO. Пользователям более ранних версий ПО, срок бесплатного обновления которых истек до 01 апреля 2018 г., будет бесплатно предоставлена возможность перехода на версию 4.10.3; для этого следует обратиться к авторизованным партнерам Trimble или в службу технической поддержки Trimble.

Приемники ГНСС Trimble для референсных сетей, произведенные после 2000 г. , с МПО версии не ниже упомянутой далее минимальной будут штатно функционировать после наступления события GPS WNRO. Далее указаны наименования приемников с минимальной / рекомендованной версиями МПО.

  • Trimble Alloy: любая / 5.37
  • Trimble NetR9: любая / 5.37
  • Trimble NetR8: любая / 48.01
  • Trimble NetR5: любая / 48.01
  • Trimble NetR3: любая / 48.01
  • Trimble NetRS: 1.3-2 / 1.3-2

Приемник ГНСС Руснавгеосеть Фаза+ для референсных сетей после наступления события WNRO будет функционировать штатно с МПО любой версии.

В качестве программного обеспечения для референсных сетей  Trimble рекомендуется использовать Trimble Pivot Platform версии 4.1.3, штатное функционирование которой после наступления события GPS WNRO подтверждена испытаниями. ПО Trimble GPSNet/RTKNet версии 2.7X проверено в условиях наступившего события GPS WNRO с подтверждением корректного функционирования. Ожидается штатное функционирования всех версий ПО Trimble VRS³Net.

Дополнительные материалы:

Об авторе sergey romanovskiy